checkra1n用プロジェクトpongoOSでゲーム「DOOM」の起動に成功!「Pongo Doom」が公開される

(19)

なにかデバイスがあればゲーム「DOOM」を起動したくなる…そんなハッカーさんが世の中にはたくさん居ます。その中のひとり…V1ridus氏がpongoOS上でDOOMの起動に成功したとのこと…!
これが何かの役に立つかと言われると微妙なところなのですが、pongoOSではこんな事も出来るよ!ということで…!!

スポンサーリンク

pongoOS

PongoOS】とは、checkra1nを利用してiOSデバイスで他のOSなどを動かそうという物です(他のOSを実行するための作業を簡略化してくれる物…というイメージ)。
機能自体は限定的ではあるものの、既に「Linux」や「Android」、簡易なゲームなどをiOSデバイスにて動作させることが可能となっています。

DOOM

そんなpongoOSにて、今度はゲーム「DOOM」を動作させることが出来るように…!
V1ridus氏により「Pongo Doom」が開発・公開。ソースでの公開なため使用するにはビルド作業などが必要となりますが、実際に動作させることが出来るようです。

また、動作させている場面がこちら。

初代をベースに

こちらは初代DOOMをベースに、pongoOS上で動作させた物となっているそうです。
ただし、今のところはサウンドの再生やセーブ、キーボード操作といった部分は動作しないようで、プレイ出来るというわけではありません。

とはいえ、動作させたというだけでも…すごいこと!スペック的には動くのでしょうが…pongoOS、なかなか侮れない…。

今回の話題単体で見ると「ネタ」的な要素を感じてしまいますが、pongoOS全体で見ると面白い動きでしょうか…!
pongoOSの将来性には期待できるものの、どうしてもその性質上動きが遅れがちな部分でしたので、こういった物が出てくると…楽しい限り!今後にも期待しちゃうところです!

コメント

  1. iPhone xs iOS13.3
    unc6.1.2 で脱獄しています。
    脱獄前はvpn使えるのですが脱獄後はvpnが使えません。
    オンを押してもオフに戻ってしまいます。
    どなたかご存じであれば何でも良いので情報教えてください。
    よろしくお願いします。

    • A-font入れてたらiCleanerとかでオフにしてみてくださいー、自分も同様の症状で恐らくA-fontが原因だったので

      • 私も起こってたから何かと思ったら…
        他にいいフォントのツールないかな

        • 他のフォントtweak探しましたが現状A-FONT以外動きそうにないですね(泣

          • 種類が多くはないですがSnowBoardのFonts Extentionつかってフォントテーマ適用するとかありますよー

  2. 迅速な返信ありがとうございます!
    確かにa-fontオフにしたら直りました(*´ω`*)
    フォント変更したいので悩みどころですorz

    • A-Font 1.8.3にダウングレードしたらVPN使えましたよ。
      iPhone12 iOS14.1 unc6.12

    • tweakに頼らず自分でフォントファイル編集して上書きするのが一番ですよ

  3. そんなことより新しいwebkitについて解説して欲しい〜!

    • そんなことよりではないし、特別新しいWebKitはリリースされていないですよ

    • そんなことなんて軽い言葉で片付けられるほどの事じゃないです

    • 興味ないかも知んないけどね。
      すごいことなんだぜ、これ。

  4. Call magicの類似アプリないですか?

    • それすごく同じこと思ってます
      探してもなかなか見つからないなぁって…。
      声変えるだけならVoicechangerXSがiOS14に対応してるけど音楽再生機能がない😭

  5. そう言えば去年あったAndroidOSのやつどうなったんだろ。

  6. iPad 7 iOS13.4.1 unc
    私の端末はLDRestartをするとリンゴマークが5分ほど表示され再起動されちゃいます、、、どういうTweakが悪さしてるのでしょうか?

    • どんな脱獄アプリが…といわれると難しいところです…。これは単体で原因となるものもあるのですが、複数組み合わさることで…という場合もあるためです…。

  7. 内容違いで恐れ入ります。今日から開始の空間オーディオですがiOS14.3に対応しているかご存じの方教えていただけますか?

    • Appleの公式覗いてみたら

      7. iOS 14.6、iPadOS 14.6、macOS 11.4、またはtvOS 14.6以降で利用できます。

      8. AirPods、AirPods Pro、AirPods Max、BeatsX、Beats Solo3 Wireless、Beats Studio3、Powerbeats3 Wireless、Beats Flex、Powerbeats Pro、Beats Solo Proに対応します。

      9. iOSの最新バージョンを搭載したiPhone 7以降、iPadOSの最新バージョンを搭載した12.9インチiPad Pro(第3世代以降)、11インチiPad Pro、iPad(第6世代以降)、iPad Air(第3世代以降)、iPad mini(第5世代)、MacBook Pro(2018モデル以降)に対応します。

      と書いてありましたよ!

タイトルとURLをコピーしました