[03/15版] iOS 5.1 脱獄の状況まとめ [まとめ]

(25)

今日現在(2012年3月15日)でのiOS 5.1 脱獄に関する事をまとめておきます。

新たに動きがあった場合には、随時更新していきます。

スポンサーリンク

注意

極力iOS 5.1にはアップデートはしない!

iPhone 4S・iPad 2においてはiOS 5.1に更新してしまうと、iOS 5.0.1等へダウングレードすることが出来ません!
これはSHSHを取得してある、取得していないに関わらず、ダウングレードすることが出来ないのです。
ですので、脱獄環境を維持したい方は絶対にiOS 5.1にアップデートしないでください。

また、それ以外の機種ではSHSHさえ取得されていればそのバージョンへのダウングレードは可能です。
【[iOS] iOS 5.1からダウングレードする方法 for ~A4「Redsn0w」】
ですが、SHSHの破損やダウングレード失敗といった可能性も捨てきれませんので、特別な理由がない方はiOS 5.1に近づかないようにしましょう!

仮脱獄 について

仮脱獄とは何か? 運用方法は?については下記記事を参考にしてみてください。
【[iOS] iOS 5の仮脱獄 & 仮脱獄の運用方法と注意】

また、仮脱獄するべきか?については下記記事を読み、判断していただくと良いかと思います。
【[iOS] iOS 5 脱獄に関する『Q&A最近よくある質問』 [まとめ] #仮脱獄はするべき?】

iOS 5.1脱獄 対応状況

今日現在(2012年3月15日)での時点で、iOS 5.1ではiPhone 3GS(旧ブート)を除いたデバイスにおいて仮脱獄のみ対応であり、iPhone 4S・iPad 2では仮脱獄すら未対応となっています。
iPhone 3GS(旧ブート)のみは完全脱獄を行うことが可能となっています。

Redsn0w

present-conditions-ios51-01

Sn0wbreeze

present-conditions-ios51-02

iOS 5.1 脱獄の開発状況

現時点では有力な情報は出てきていない物の、pod2g氏がiOS 5.1脱獄へ向けた脆弱性探しの作業へ入ったことが分かっています。
【Pod2g氏が iOS 5.1 完全脱獄の開発に取り組み中! ロマンだな!】

コメント

  1. 旧bootRomの3GSは紐無し脱獄が出来るみたいですが、どうすればいいんでしょうか?
    あと、脱獄出来てもultrasn0wは5.1に対応してないですよね?

    • ios5.1を旧ブートロムでの完全脱獄はredsnow起動してjailbreakを選択して
      から電源を切って起き(電源を切らないとnextに進まない)DFUモードに手順どおり
      進めてきます、そしてcydiaにチェックを入れて完了するまでまてば出来上がりです^^

      ちなみにまだultrasnowに対応してないのでsim解除、シムフリーにはなりませんので
      注意してください。

      • ultrasn0w-1.2.5 をiOS-5.1に対応させるultrasn0w fixer for 5.1がすでに出ていると思うのですが。で実際動作しますが。

    • 通常通りRedsn0wやSn0wbreezeにて脱獄作業を行っていただければ問題ありません。

      Ultrasn0w自体はiOS 5.1に対応していませんが、Ultrasn0w fixer for 5.1というものが「repo.iparelhos.com」からリリースされています。
      使用可能ですが、第三者の作成ですので、不具合等に注意してください。

  2. iPhone4SをAbsintheにて脱獄していましたが本体設定にてリセット〜全てのコンテンツと設定を消去を選択したところcydiaにアクセス出来なくなったのですが・・・これはもう時既に遅しなのでしょうか・・・泣

    • 脱獄済みデバイスにて、すべてのコンテンツと設定を消去は実行してはだめな項目です。
      再起動しても駄目な場合は、再度Absintheを実行してみてください。
      ただ、不具合などが出るかもしれませんので注意してください。

  3. 5.1の4Sのプロセス見てみたらabsinthed.N94が有った・・・・

    There is also a daemon named absinthed.XXX.

    • 復元では無く、アップデートを行いませんでしたでしょうか?

  4. 3GSの旧ブートでSn0wbreezeにて完全脱獄作業を行いましたところMAP上で現在地検出されなくなりました。回復方法はありますか?

    • 自己レスです。
      Redsn0wでの3GSの完全脱獄では現在地は問題なく検出されました。

    • 詳しい状況が分からないので何とも言えませんが、CFWの作り直しや、他の脱獄ツールを使って脱獄してみて下さい。

  5. CYdiaが起動しません
    iPhone4

    • iOS 5.1でしょうか?
      そうであれば仮脱獄となりますので、Redsn0w「JustBoot」機能を使用して脱獄環境として起動してあげて下さい。

  6. 一度、仮やたら、もどすのは、不可能?

    • iTunesで復元すれば、戻せます。

    • iOSの復元を行っていただければ入獄環境となります。

  7. iPhone4 5.0.1(母艦はMac)の調子が悪くなったため、5.1で復元しました。
    そこからredsn0wでpwned sfuモードに突入させた後、
    iTunesを使ってcfwで5.0.1にダウングレードしようとしているのですが、
    復元がある程度進んだところでiTunesにエラー1が表示され、iPhoneは「USBに接続しろ」画面がでた状態となって復元ができません。
    Youtubeなどにある解説動画を見る限り、同じような手順を踏んでいるのですが…
    どうしたらよいかご存じでしょうか?

  8. 5.0.1への復元ができました。
    たびたびすみませんが、今度は5.0.1からredsn0wで脱獄するときにエラーが起こるようになってしまいました。
    Mac版0.9.10b6b、0.9.10b6と試しているのですが、いずれのバージョンでも「Exploit failed」と表示されます。
    (脱獄をする前に、Select IPSWでもともとのiPhone4 5.0.1のファームを指定してます)
    これの解決策があれば教えていただけると助かります。

    • redsn0w 0.9.10b5であっても変わらず起こっていますでしょうか?

  9. 0.9.10b5で出来ました。
    丁寧にご回答いただきありがとうございました!

  10. 完全脱獄、5.1まだ?

  11. btさんと同じです。
    ・5.0.1 旧bootromはusb viewでiBoot-359.3 Old-bootrom
    ・winxp sp3(最近)

    redsn0w 0.9.10b5c 「5c」ってバージョンで
    落ちまくってましたが
    5回に1回、インストールチェック項目まで行けました。
    ipad-BBの読み込みで100%落ちるので、Cydiaのみを導入しました。
    仕方なく、Cydiaだけ導入はできました

    全てアプリ入れた後、

    後からi-pad BBを入れようにも、redsn0wで以下の文面が出て弾かれます
    今回は初回読み込み終わった辺りで出ます。(first stage直後あたり)

    this device is already pwned with a bootrom exploit.

    for the time being, redsn0w requires that you manually select the ipsw inthe extras screen in order to specify the current build.

    this will be fixed in a future release.

    と、出て弾かれます。

    直訳だと、この装置は、既にbootrom功績で完敗しています。
    当分の間、redsn0wは、あなたが手動でipsw inthe余分の物を選ぶことを必要とします、現在の構造を指定するために遮ります。
    これは将来のリリースに固定されるでしょう。

    シリアルからも旧bootのギリギリラインだったので、
    なにか特別な端末だったりするのでしょうか。

    「0.9.10b5c」ではなく「0.9.10b5」で最後に試みましたが、
    落ちる
    または
    上記、同じエラーで弾かれます。

    違うものでSnowbreezeなどありそうですが、最後に復元からだとまたこれ心配です
    もし同じ状況なら、何を試されますか?

  12. Redsn0w 0.9.10b8
    Redsn0w 0.9.11b4

    「申し訳御座いません。」とエラーで落ちます。
    結局全滅でした (笑)

    5.1.1にUPして赤雪11bでJBかけても挙動から、同じことになりそうですよね。
    BBが5.16.05ですし、新しいUltrasn0w Fixerにも対応していないので

    5.1.1なども特に魅力もないですし
    今回はSBモバイルの檻に入ったままとします!
    ありがとうございました。