TaurineやOdysseyなど向け「libhooker 1.6.9b2」がリリース、問題の修正やiOS 15対応を追加 [JBApp]

(19)

TaurineOdysseyなどで使用される脱獄アプリの親玉【libhooker】ですが、新たなベータ版である「1.6.9b2」がリリースされています。
不具合の修正に加え、今後を見据えて…iOS 15対応も行われているようです。

スポンサーリンク

libhooker 1.6.9b2

現在、正式版は「libhooker 1.6.3」が最新となっていますが、ベータ版として【libhooker 1.6.9b2】がリリース。
ちなみに、バージョン数が1.6.9に飛んでいることからも分かる通り…Beta 1は昨年9月にリリースされており、だいぶ長い期間でのベータテストとなっています。

ベータ版を使用したい場合はこちらを追加し、アップデートを行いましょう。
*あくまでベータ版なため、不具合等には十分ご注意ください*

https://repo.theodyssey.dev/libhooker-beta/

update-libhooker-169beta2-for-taurine-and-odyssey-add-ios15-support-2

変更内容

  • iOS 15へのサポートを追加
  • 1.6.9b1にてWebContentのフック関連に問題があった点を修正
  • メモリフックに関する問題を修正

今回「iOS 15対応」が追加されていますが、現時点ではiOS 15の脱獄は行なえませんので、あくまで「今後を見据えて…」という意図になっています。
ちなみにlibhookerはiOS 14の時も先んじて対応を行っており、実際の脱獄が行えるようになった際もかなりイイ感じに仕上がっていました。
そのため、今後iOS 15脱獄が可能になった際にも、ある程度イイ感じの動作が出来るように…なっているかも…?!

コメント

  1. そういやSiguza氏あと一週間程度の作業でcheckra1niOS15対応するとか言ってたけど進行具合どのくらいなんだろ

    • 報告時点では「忙しくて作業が出来ない、作業を開始できれば1週間程度で完了すると思う」ということで、作業が行われていたわけではありません。
      そのため、まずはSiguza氏が暇になるのを待つしか…という感じでしょうか…

    • 楽しみですよね~

  2. ios12.4な6s+なunc0ver環境なんですけど、macしかなくてaltが今アレなんで、
    checkra1nで脱獄してunc0ver入れて再署名してunc0ver環境へってアリなんでしょうか?

    • iOS14.3の初代SEがあるんだけど、14.8にあげてCheckra1nで済ますか悩み中です。
      Alt問題考えるとiOS12.xなら上げておくのアリだと思います。

    • 普通にあり

    • 自己レス
      同環境で、最新の8.0.2だと、6/32で落ちる
      ぐぐるとradditに5.3.1でやれってあったのでそれでやるとすんなり成功
      その後8.0.2に上げてもやはり落ちるので今後は5.3.1で運用することに
      checkra1nとの共存は6以上でとの事なので少し不安はあるがしゃーなし

      • さらに自己レス
        署名失うまで安定してたんだけど、unc0ver環境で度々再起動がかかる
        最初はunc0ver5.3.1で再脱獄できてたんだけど、1/31で脱獄成功のメッセージ出て脱獄できなくなった
        checkra1nでも脱獄できなくなって詰んだか?と思ったがセーフモードで脱獄できたのでとりあえずicleanerでtweakを全部無効に
        それでもやはりunc0verでは脱獄できず
        checkra1nでは通常脱獄できてるのでこのまま使うかなあ

  3. Siguza氏は、クリスマスまで忙しいが、そのあと、作業してるんじゃないですか?

  4. 失くしたApple Watch‎が見つかってiPhoneと再ペアリングしようとしたら、Apple Watch‎がwatchOS8でiPhone XがiOS14なので互換性がなくペアリングが出来ないので、iOS15に上げようか迷うのですが上げても問題ないでしょうか。
    iOS15がまだ不具合がありそうで怖いです…

    • watch持ってなくて興味もないからよく覚えてないけど、
      iosのペアリングバージョン制限取っ払うtweakがあったよ

    • LEGIZMO

      • Legizmoはベータ版も含め対応バージョン等に違いがあり、不安定な組み合わせなどもありますので、ご使用になる際はコミュニティをチェックしてからご判断ください。
        https://www.patreon.com/lunotech11

      • 教えてくれて有難うございます!
        無事同期出来ました!

  5. 大丈夫ですよ。自信をもって上げ上げ!

  6. Odysseyいいなぁ(T▽T)

    A15 ios15.2 絶望的…

    • とりあえず15.1.1待機しときゃええんちゃう?

      • 届いた端末がiOS15.2でした。
        Odyssey安定してて使いやすかったなぁ…(´・ω・`)ショボン

タイトルとURLをコピーしました