Extenderの進化版「ReProvision」が開発中、iOS 9〜11.4に対応し全デバイスで使用可能に

(52)

Ext3nder Installerなど、いわゆる【Extender】シリーズの進化版とも言える【ReProvision】の開発について報告が行われています。
従来のバージョンから機能などを引き継ぎつつ、自動再署名でのバッテリー消費を抑え、デザインの変更などが行われるようです。

更に、32bitデバイスにも対応するというサブ機などには嬉しい報告も…!

スポンサーリンク

ReProvision

Matt Clarke氏が【ReProvision】と呼ばれる新しい脱獄アプリ(Extender Reloadedのアップデートとして提供)を開発中と報告してくれています。

元となっているのは『Extender』とのことで、基本的な機能としてはデバイス単体でアプリの再署名が行えたり、自動で再署名を行う、いわゆる7日問題を解決するためのアプリ。

デザインの変更

まず一番わかりやすいのが、デザインの変更。Electraチームのデザイナーでお馴染みAlessandro Chiarlitti氏が担当しているそうです。

upcoming-ext3nder-alternative-reprovision-matchstic-20180720-2

自動署名のバッテリー消費を抑える

また、機能面で言いますと、自動再署名のバッテリー消費を抑える様に作り変えられているそうです。

Ext3nder Installerなどでは、何時間に1回確認を行うか?という設定が用意されており、その設定によってバッテリー消費が増減していました。
ですが、今回の【ReProvision】ではその設定自体が排除されているそうで、別の確認手法が取られるようです。

iOS 9〜11に対応、32&64bitデバイスに対応

また、これまで多くのExtenderは全機能を使おうとすると、iOSバージョンによって違う物を使ったほうがイイ…なんてケースがありましたが、今回は一括でiOS 9〜11.4までに対応とのこと。

更に、Extenderでは未対応である32bitデバイスにも対応しているそうです!
サブ機などで脱獄をしていると、32bitデバイスを使っている…という方も多くいますので、そういった場合にすっごい便利!

Electra MP版をご使用の方は不要となりますが、過去バージョンも含めて対応している…ということなので、個人的には過去バージョンで脱獄しているデバイスは全てこちらに切り替えてしまおうかなと思っていたり。
特にテスト機として使っていたりするデバイスは毎日触るわけではないので、7日問題の事を忘れてしまって、面倒だったのですよね…。
32bitにも対応ということで、個人的には地味に嬉しい…!

コメント

  1. 今のExte3derって、Revokeうまくできないっぽい?けど、なんとかなるのかな??

    • Revokeうまくできないってどういうこと?
      Ext3nderじゃないの?

    • 同じID使い回してたり?

    • Impactorの話だよね?w
      最新バージョンの[0.9.44]はRevokeの不具合出るから、
      ひとつ前のバージョン落として、実行ファイルの[impactor.exe]を
      [revoke.exe]とかにリネムって、[0.9.44]のフォルダに保存。
      Revokeかけたい時だけそっち使えば恐らく解決。

      • Ex3nderの話だろ

      • ImpactorでRevokeしとけばExt3nderでもいけるってこと?

  2. 英語の意味多分間違って捉えてるね

  3. 32bit対応嬉しすぎる

  4. iPhone X 11.3.1で、Activatorが動かないの俺だけ??
    なんか動かす方法ない??

    • 現在使えるのbeta版のみ

      • だから動かねーって言ってんだろ

        • だからベーターのみっているだろ

  5. 9.3.5でリジェクトされたiPadをPhoenixで脱獄して
    これ使えば…
    ありがとうございます!

  6. ReformX for iOS 11使ってる人いる?

    • 使えてるよ。

  7. 7日間問題ってアプリ側が企業用署名にすれば良いだけじゃないの?

    • ???

    • それが簡単にできないからこうなってるわけで…

    • 企業署名は365日でしょ。成功率の低いVFS版で頑張って脱獄して7日対策してる方が長く使えるの?

    • Ext3nder使えば実質無限だから365日の企業署名より良いゾ

      • 1年も経てば一回は脱獄が来るんだよ。

        • そんなことなくないですか?
          iOS10とかまともな脱獄なかったし…

  8. ignition.funの
    Electra MPTCPって無くなってない?

    • あるように見えますが…

  9. 32bit h3lixで使える

  10. 32bit対応ktkr!

  11. だれかAbemaTVの脱獄回避できるアプリ知ってる人いない?∵⃝♡⍢⃝ ⍤⃝ ⍨⃝ ∵⃝♡⍢⃝ ⍤⃝ ⍨⃝ ∵⃝♡⍢⃝

    • xCon 42-beta2で行けてます。ios10.2 iPhone5sですが…

      • ios11ではxCon不可だけどね

    • Liberty liteでいけるよ

    • おまえのiOSバージョン知らんから分からん

  12. なんでMPを使わないの?
    これ自体は今後のためにも過去の脱獄を維持している人には意味はあると思うが

  13. A10デバイス ios10.3.1でも使用可能!?

  14. SANTAさん、いつもの素敵な情報をありがとうございます。

  15. Electra1.0.3で脱獄してるのですが再起動させてから脱獄状態に復帰できないです
    だれかアドバイスお願いします
    バージョンはIOS11.4ベータ3です

    • 7日問題って知ってる?

      • 知ってますよ
        脱獄自体はiPhone3GSの頃からしてるのである程度知識はありますが
        今回の件に関しては成功率の問題なのか全然成功しないのでアドバイスを聞きたくコメントしました

        • 3GSの頃からって、そうであればここに書いてあることは全て把握できるでしょうから、若輩者からはアドバイスできることは残っていないと思うのだが…
          どうしても問題が解決できないならば、入獄してリセットして再構築する手間を惜しんではいけないと思うな。

          • 色々試行錯誤してるのですが今回の成功率はかなり難しく自分が把握してないやり方で成功している人がもしかしたらいるかもしれないので…

            また残念ながら入獄するにしてもSSH接続が不可能でDelectraが使えないです。
            すでにElectraでtweaksをオフにしても同じことが起こるので。

            semiRestore11/Rollectraも脱獄状態に復帰できないためインストール不可

            11.3.1のshshは持っているけど11.4beta3の為使用できない

            以上の理由から入獄するにしても最新バージョンになってしまうため脱獄の再構築以前の話になってしまうため入獄は不可能なんです

        • FilzaEscapedのコメントが参考になるんじゃね?

        • 現状(Electra)の脱獄に拘りがありつつも、Face IDやTouch IDが使用できなくなることが受け入れ可能ならば iOS 11.3.1 にしてしまえば良いと思うけど、どうしてもダメなら今の状況で我慢するしかないのではないかな?
          状況が申告通りなら実質的には脱獄できていないのと同じようなものなので、iOS 11.3.1 にして試してからでも、その後に諦めて iOS 11.4.1 にしてしまうとか…

          • 11.4beta3にしてしまってるからダウングレード出来ないと思うけど…

          • Futurerestore

    • 11.3.1でない環境、しかもベータ版iOSで、そこまで使い勝手の悪い状況を維持する意味はないと思う。
      VFS版の成功率はほんと萎える。

      2回リスプリング、その後Enable Jailbreakを10秒直前で実行すると比較的成功してたな。。。

      ちなみに6の11.3.1だったが、それでも嫌気がさしMP版にしたら、劇的に成功率は高いから、今まで何だったのかアホらしくなった

    • Xは持っていないので分からないけど、VFS版はそんなに成功しないのか? 7の11.3.1だとあまり変わらないけどなぁ

  16. 関係のない質問で申し訳ないのですが、iOS11下のSileoでは、有料脱獄アプリの新規購入は可能になるのでしょうか?

    • 可能にするためにSileoになるじゃん?

    • 現状、Cydiaでも新規購入はできますけどね

    • Packixと同じ様な購入システムが採用されるはずです

  17. 4S 9.3.5 でもいけるのかな。

    • いけるはず

  18. きたー!!