前バージョンCydia Impactor v0.9.43をダウンロードする方法、「provision.cpp:81」エラー等の対策に

先日、アプリのインストールが行えなくなったために、その不具合を修正した「Cydia Impactor v0.9.44」へとアップデートが行われました。
ですが、最新版であるv0.9.44はインストールは出来る様になった物の…逆に「provision.cpp:71」や「provision.cpp:81」といったエラーへ対処するための機能「Revoke Certificates」が使えない状態に…。

そこで、Revoke Certificatesを使える前バージョン「Cydia Impactor v0.9.43」のダウンロード方法について記載しておきたいと思います。

スポンサーリンク
336

Cydia Impactor v0.9.43のダウンロード

Cydia Impactorのダウンロードリンクは、通常最新版をダウンロードする共通URLとなっているのですが、Saurik氏のサーバー側にはきちんと過去バージョンも残っています。
そのため、以下のリンクからダウンロードしていただく事で、Cydia Impactor v0.9.43をダウンロードすることが可能!(*Mac版はv0.9.43が無いのでv0.9.42となります)

Mac OS X版
Windows版
Linux 32bit版
Linux 64bit版

Revoke Certificatesはv0.9.43で

provision.cpp:71】や【provision.cpp:81】といったエラーが出た場合、多くはImpactorのメニュー「Xcode > Revoke Certificates」機能を一度使うことで解消可能。

そのため、最新版であるCydia Impactor v0.9.44でアプリをインストールする際にこれらエラーが発生した場合は、一度0.9.43でRevoke Certificatesを行ってください。

インストール自体はv0.9.44で

ただし、v0.9.43ではインストール自体はエラーが発生してできませんので、Revoke Certificatesを行った後はCydia Impactor v0.9.44にてインストール作業を行いましょう。

別フォルダに置いておくとv0.9.43とv0.9.44は共存出来ますので、とりあえずRevoke Certificates機能の修正が来るまではこの方法で…!

頻繁に使う物ではありませんが、発生するとRevoke Certificatesを使わないと治らないので一瞬焦るんですよね…。ということで、頭の片隅にでも…。

スポンサーリンク

コメント

  1. 名前:匿名 投稿日:2018/02/22(木) 16:24:27 返信

    無事にインストール出来ましたよ、助かりました!!

  2. 名前:匿名 投稿日:2018/02/22(木) 16:46:55 返信

    そうだったんだ…
    今朝7日周期が来ていてインストールできなくて困っていたところだった。
    後から記事通りにやってみよう

  3. 名前:匿名 投稿日:2018/02/22(木) 17:34:50 返信

    エラーでるから新たに捨てID作った

  4. 名前:匿名 投稿日:2018/02/22(木) 18:14:13 返信

    ググったら英語のサイトでこの方法紹介されてたけどわかりづらかったから
    ありがたや。。

  5. 名前:匿名 投稿日:2018/02/22(木) 19:52:08 返信

    自動でRe-signしてるから、Impactorはもう何ヶ月も使ってないなぁ

    • 名前:匿名 投稿日:2018/02/23(金) 02:04:17 返信

      そのre-signが機能しなくてあせったわww

  6. 名前:匿名 投稿日:2018/02/22(木) 21:46:18 返信

    ちょうどエラーで困っていたので助かりました!

  7. 名前:匿名 投稿日:2018/02/24(土) 16:00:51 返信

    昨日、Filzajailbreakがインストール出来なくなった…(versionエラー) Tweakboxからインストール😅

  8. 名前:匿名 投稿日:2018/02/25(日) 19:14:48 返信

    tutuappからg0blinインストールして脱獄してるけど特に支障ないのかな?

  9. 名前:匿名 投稿日:2018/02/28(水) 20:14:32 返信

    filzaescapedを入れようとするとinstallation.cpp:51 APIInternalErrorて出てくるんですけど何が原因かわかる方いらっしゃいます?

  10. 名前:hackjack 投稿日:2018/02/28(水) 21:20:20 返信

    いつもありがとうございます。JBできました。
    provision.cpp:168 とか 173 で困ってる人いたら、2ファクタ認証が問題なので、Apple ID管理からApp用パスワード作成してそれを入れれば解決します。

  11. 名前:匿名 投稿日:2018/03/02(金) 16:09:17 返信

    すみません、教えてください。
    electraのアップデートを行おうと思いv1.0.2のipkをimpactorにてインストールしようとしたのですが、最新版の0.9,44で行うとcpp:62エラーが出てしまい、バージョンを下げて0.9.42で行うとcpp:71エラーが出ます。以前v.1.0.1をインストールした際はこれらのエラーは出なかったと思うのですが、同じ症状の方、解決された方いましたら教えてください。2ファクタ認証はオフ、アカウントを新しく作りやり直す、xcode欄のrevokeなど試しましたが結果は同じでした。よろしくお願いします。

  12. 名前:匿名 投稿日:2018/03/12(月) 22:54:36 返信

    impactor_0.9.44でrevoke certificatesを使用としたらprogress.hpp:87_assert(false)と出るのですがどうすればいいでしょうか?
    よければ教えてください

    • 名前:匿名 投稿日:2018/03/20(火) 02:45:42 返信

      この記事に対処法が書いてあるよ。
      一旦、ver0.0.43のimpactorでrevokeしてから、ver0.0.44のimpactorでyalu102を再インストール。

      それよか早くextenderで自動インストールしてくれるようにrevoke certificate機能を修正したバージョンがリリースされないかな…

コメントを投稿