A7 / A8デバイスでも「iOS 12.0〜12.1.2向けExploit」が動作可能に、tihmstar氏がリリース

(12)

現在iOS 12.0〜12.1.2の脱獄開発ではBrandon Azad氏が公開した「voucher_swap exploit」が使用されていますが、A9以降(正確にはA8X以降)にしか対応していませんでした。
そのため、A7 / A8デバイスでは使えない状況に…。

が、tihmstar氏により改良が行われ、A7 / A8デバイスのiOS 12.0〜12.1.2にも対応となったよ!

スポンサーリンク

A7 / A8デバイスに対応

tihmstar氏より「A7 / A8デバイス(iOS 12.0〜12.1.2)にExploitを対応させた」との報告が行われ、そのコードも公開されています。

Patchfinderなどの対応が遅れているため、各種ツールがまだA12デバイスに対応出来ていませんが、Exploitで言いますと…これにより全デバイスで使用可能となった事に!

Exploitは…

今回報告されたExploitは「v3ntex」という名で、「voucher_swap」を元に作られたA7 / A8デバイス(iOS 11.x)用のExploit「v1ntex」の改良版となっているようです。
要するに…A9〜A12向けである「voucher_swap」の派生版といった感じでしょうか。

まだ未完成

v1ntexのときと同じく、tihmstar氏はある程度形にした段階でリリース…という事で、まだ完成とはなっていないようで、いくつかの調整とオフセットの追加やPatchfinder対応が必要となっている様子。
とは言え、既に開発者さんからは成功報告なども出ているので、使える物に変わりはなさそうですねっ!

rootlessJB3がA7 / A8に対応へ

これにより、半脱獄…とでも言う仕様であるrootlessJBが、今回のExploitを組み込み、A7 / A8対応させる予定とのことです。
まだ調整不足であったり、先述のようにPatchfinder対応が行えていないのですが、とりあえず…対応させるみたい。

ということで、これにより一応全デバイス&iOS 12.0〜12.1.2に対応となったExploit…!
ちなみに、A7 / A8デバイスとは以下のもので、対応するかドキドキしていたのですが…良かった…良かったよ…!テストデバイスが増えたよ…!

  • 【A7】:iPhone 5s / iPad Air / iPad mini 2 / iPad mini 3
  • 【A8】:iPhone 6 / 6 Plus / iPod touch 6 / iPad mini 4

コメント

  1. サブのiPhone6もいじれるの楽しみ🤣

  2. ようやく来ましたね!

  3. 順調ゥー!

  4. A12のrootlessJBだけでも期待する日々

  5. ありがてえなあ…
    久々にワクワクする

  6. 脱獄にできるのはもう少しなんでしょうか?入獄状態で使いにくいです。

  7. iPad air2はできないのですか?

  8. weN eTa A12
    i CaNt wAiT

  9. 現在、Cydiaにあるtweakはインストールできなくなる?

    • いいえ、そうはなりません

  10. 失礼します。ipad(6世代)12.1.1は対応しているのでしょうか?

    • 元々のExploitで既に対応されているはずです