iOS 11.x脱獄「unc0ver v2.1.1」のテストが開始、v2.1.0であった各種バグを修正

(7)

iOS 11.0〜11.3.1(iOS 11.4 Beta 3)の脱獄を行う【unc0ver】ですが、先日リリースされたunc0ver v2.1.0では細かなバグが多くあった様でした。
本日、これらのバグ修正を目的とした「v2.1.1」のテストが開始されています。

スポンサーリンク

unc0ver v2.1.1

unc0ver v2.1.1】のテストが開始されています。現時点では【Pre-Release】という位置づけで、あくまでテスト版

これまで同様、TweakBoxでは正式リリース後に反映されると思われ、ご使用になる場合はipaファイルをダウンロード&Impactorでインストールする必要があります。

更新内容

  • 脱獄作業の速度を改善
  • hostsファイルが存在しなくても、エラーにならないように
  • Cydiaの再インストール時、依存関係を無視する様に
  • 誤検知が発生していた問題を修正
  • RootFS Restore(入獄オプション)時、Cydiaのユーザーデータを完全削除する様に
  • RootFS Restore時のスナップショット名に関する問題を修正
  • その他、RootFS Restoreに関するバグを修正
  • メモリ管理に関する改善
  • 外部バイナリの容量を小さくしました
  • 【既知の問題】CydiaとOpenSSHの再インストールオプションに問題が発生中です(2019/1/6時点)

今のところテスト版で、これ自体にもいくつかバグが報告されているため、すぐに使用…はあまりオススメできませんが、v2.1.0であったバグがきちんと修正されていれば嬉しいところですね。
報告を見る限り、脱獄作業が途中で止まってしまう問題が修正されたという方も居るようなので、期待期待…!

コメント

  1. electraからuncOver2.1.0に移行する際、Rollectraでの初期化は必要ですか?

    • どこかのバージョンから初期化無しでそのまま乗り換えできるようになってたよ

      • 2.1.0の記事でそのように書かれてますね。
        私は古いバージョンで失敗しますた。

  2. インストール時に必要となるパッケージがと表示され
    脱獄アプリがなにもダウンロードできなくなりました。
    乗り換えなので、まだアプリはなにも入れてない状態なのですが( ; ; )

    • ご使用のバージョンやデバイス、乗換方法、エラー内容などは、具体的にはどの様になっていますでしょうか?
      また、リポジトリの更新を行った際に、何かしらエラーやアップデートが表示されたりはしていませんでしょうか?

      • SANTAさん返信ありがとうございます!
        ios11.2.1 iPhone8 extraからunc0ver v2.1.0に乗り換えです!
        リポジトリ更新のエラーは知識不足の為理解できなかったです。
        Depends Cydia Substrate
        Depends uasharedtools>=2.2r-61
        と表示されています!

  3. ios11.2.1 iPhone8 extraからunc0ver v2.1.0に乗り換えです!
    リポジトリ更新のエラーは知識不足の為理解できなかったです。
    Depends Cydia Substrate
    Depends uasharedtools>=2.2r-61
    と表示されています!